const regex = /^[a-zA-Z]{3,4}(\d{6})((\D|\d){3})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]{3,4}(\\d{6})((\\D|\\d){3})?$', '')
const str = `CUPU800825569`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}