const regex = new RegExp('\\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\\b', 'gi')
const str = `yest
yeste
yester
yesterd
yesterda
yesterday
tod
toda
today
tom
tomo
tomor
tomorr
tomorro
tomorrow
yesteray
tomorow
tommorrow
tody
yesteday`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}