#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^a-zA-Z]|^)(?:X-Men|prof[esor]{0,6}\.{0,1} x|wolverine|new mutant|captain britain|x-force|magneto|cyclops|chris claremont|deadpool|kamala khan|orchis|emma frost|magik|illyana rasputin|illyana rasputina|boom-boom|carol danvers|krakoa|alpha flight|starjammer|house of x|powers of x|fall of x|krakoa|x-feed|xmen|x men|#xmen|betsy braddock|x-tober|x-tober24|nightcrawler|#x-men|#x-tober2024|x-statix|krakoan)(?:[^a-zA-Z]|$)"
Local $sString = "deadpool"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")