use strict;
my $str = 'deadpool';
my $regex = qr/(?:[^a-zA-Z]|^)(?:X-Men|prof[esor]{0,6}\.{0,1} x|wolverine|new mutant|captain britain|x-force|magneto|cyclops|chris claremont|deadpool|kamala khan|orchis|emma frost|magik|illyana rasputin|illyana rasputina|boom-boom|carol danvers|krakoa|alpha flight|starjammer|house of x|powers of x|fall of x|krakoa|x-feed|xmen|x men|#xmen|betsy braddock|x-tober|x-tober24|nightcrawler|#x-men|#x-tober2024|x-statix|krakoan)(?:[^a-zA-Z]|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}