using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^>\s]+)[^>]*>(?:\s*(?:<br \/>| | | | | | | )\s*)*<\/\1>";
string substitution = @"";
string input = @"<div>
<h1>This is a html structure.</h1>
<p>This is not empty.</p>
<p></p>
<p><br /></p>
<p> <br />  </p>
<p> </p>
<p> </p>
</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}