re = /<([^>\s]+)[^>]*>(?:\s*(?:<br \/>| | | | | | | )\s*)*<\/\1>/m
str = '<div>
<h1>This is a html structure.</h1>
<p>This is not empty.</p>
<p></p>
<p><br /></p>
<p> <br />  </p>
<p> </p>
<p> </p>
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result