#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)"
Local $sString = "<p><img class="classIWantToMatch" src="data:image/gif;base64,dataForImage"></p>" & @CRLF & _
"<p><img src="data:image/gif;base64,imageData" class="classIWantToMatch" ></p>" & @CRLF & _
"<p><img src="/myFiles/my.PNG" alt=""></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")