use strict;
my $str = 'these should match
:root {
--externalcolor: red;
--samename: orange;
--samename: #0f0;
--foo: green;
--FOO: #0f0;
--halfsuccess: orange;
/* multiple on one line */
--success: green;--success2: #0f0;
/* forget the ; */
--success: green
--success2: #0f0
--fred: var(--foo);
--barney: var(--foo, test)
}
:root {
/* name options */
--4name: startsWithNumber;
--name: startsWithLetter;
/* value options */
--startWithLetter: red;
--startWithPound: #0f0;
--startWithNumber: 20px;
--startWithQuoteDouble: "test";
--startWithQuoteSingle: \'test\';
--containsUrl: url("http://test.com/foo?a=b&c=d");
--containsPunctuation: -_,.;
--containsSpace: "test space";
/* misc conditions*/
--multipleOnOneLine1: green; --multipleOnOneLine2: #0f0;
--noSpaceAfterColon:test;
--multiSpaceAfterColon: test;
--dash-in-name: test;
--underscore_in_name: test;
}
/* minified css */
:root{--almost-black:#222;}html{color:var(--almost-black)}body{color:var(--almost-black);
don\'t match this (the double dash in the comments
/* ----------------------------------------------------- */
@import url("https://fonts.googleapis.com/css?family=Roboto:300,400,500,700&display=swap");
on one line
/* ----------------------------------------------------- */ @import url("https://fonts.googleapis.com/css?family=Roboto:300,400,500,700&display=swap");';
my $regex = qr/(--[\w-]+:[\s]*[^;\n}]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}