re = /^(?! )[A-Za-z0-9 ]*(?<! )$/m
str = 'Abc132 3sdfas
asd dsadas
$das dsfds
Te st'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end