// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(degree(s)? of)(\n?|.+?)(\w.+|\w?.+\n.+)").unwrap();
let string = "MIT Sample:
AN EXPERIMENTAL INVESTIGATION OF
OIL SPREADING OVER WATER
by
Walter Suchon
Submitted in Partial Fulfillment
of the Requirements for the
degrees of
bachelor of science
and
Master of Science
at the
MASSACHUSETTS INSTITUTE OF TECHNOLOGY
April, 1970
Signature of Author
Department of Mechanical Engineering
Certified by.......
Thesis Supervisor
Accepted by
Chairman, Departmental Committee on Graduate Students
Archives
MASS INST. TECH.
SEP 10 1970
LIBRARIES
--------------------------------------------------------------
Virginia Tech Sample:
FUNDAMENTAL ADHESIVE STUDIES OF BLOCK COPOLYMERS
by
Margaret Mary Sheridan
Dissertation submitted to the Faculty of the
Virginia Polytechnic Institute and State University
in partial fulfillment of the requirements for the degree of
Doctor of Philosophy
in
Chemistry
APPROVED:
T.C. Ward, Chairman
D.W. Dwight M.A. Oglioruso
J.E. McGrath J.P. Wightman
October, 1985
Blacksburg, Virginia";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}