$re = '/^9(0\d{10})$/';
$str = '901234567890
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);