#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<protocol>(?:http|ftp|irc)s?:\/\/)?(?:(?<user>[^:\n\r]+):(?<pass>[^@\n\r]+)@)?(?<host>(?:www\.)?(?:[^:\/\n\r]+)(?::(?<port>\d+))?)\/?(?<request>[^?#\n\r]+)?\??(?<query>[^#\n\r]*)?\#?(?<anchor>[^\n\r]*)?"
Local $sString = "http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth" & @CRLF & _
"http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere" & @CRLF & _
"https://www.example.com" & @CRLF & _
"ircs://example.server.net:6697/#channel" & @CRLF & _
"irc://irc.example.org/channel" & @CRLF & _
"ftp://www.place.example.gov/" & @CRLF & _
"www.places.to.be" & @CRLF & _
"somewhere.to/go"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")