// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?<protocol>(?:http|ftp|irc)s?:\/\/)?(?:(?<user>[^:\n\r]+):(?<pass>[^@\n\r]+)@)?(?<host>(?:www\.)?(?:[^:\/\n\r]+)(?::(?<port>\d+))?)\/?(?<request>[^?#\n\r]+)?\??(?<query>[^#\n\r]*)?\#?(?<anchor>[^\n\r]*)?").unwrap();
let string = "http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth
http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere
https://www.example.com
ircs://example.server.net:6697/#channel
irc://irc.example.org/channel
ftp://www.place.example.gov/
www.places.to.be
somewhere.to/go";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}