import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{1,10}|(?![\\d.]{11,})\\d+\\.\\d+)$";
final String string = "1\n"
+ "12\n"
+ "12345\n"
+ "1234567890\n"
+ "12345678901\n"
+ "1.23\n"
+ "3.14159\n"
+ "1.12345678\n"
+ "1.123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}