#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)(?:\'s.*)?(?:\s*(?:Original|Extended|Club|Vocal|Dub|DJ|Tech|Summer of Love|12\"))*\s+(?:Remix|Rework|Remake|Reboot|Mix|Bootleg|Version|Edit)$"
Local $sString = "Original Mix" & @CRLF & _
"Vocal Club Mix" & @CRLF & _
"Vocal Mix" & @CRLF & _
"Arbe & Dann Rework" & @CRLF & _
"Protoculture Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Club Mix" & @CRLF & _
"Above & Beyond Extended Club Mix" & @CRLF & _
"Above & Beyond Mix" & @CRLF & _
"Daniel Kandi Extended Mix" & @CRLF & _
"Myon Extended Summer of Love Reboot" & @CRLF & _
"Above & Beyond Club Mix" & @CRLF & _
"Mike Shiver's Catching Sun Mix" & @CRLF & _
"Millennial's On Full Force Extended Remix" & @CRLF & _
"DJ Tiesto's Magikal Remake" & @CRLF & _
"Dustin Husain Bootleg" & @CRLF & _
"Extended Version" & @CRLF & _
"Daniel Kandi Mix" & @CRLF & _
"Above & Beyond Club Mix" & @CRLF & _
"Cosmic Gate Vocal Mix" & @CRLF & _
"Armin van Buuren Remix" & @CRLF & _
"Above & Beyond Extended Club Mix" & @CRLF & _
"Maor Levi Extended Mix" & @CRLF & _
"gardenstate Extended Mix" & @CRLF & _
"RYDEX Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Stratos Kokotas Extended Mix" & @CRLF & _
"Niko Zografos Extended Remix" & @CRLF & _
"Simon Bostock Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Cold Blue Extended Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Judah Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Hybrid's Supersonic Remix" & @CRLF & _
"Original Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Activa Extended Rework" & @CRLF & _
"DJ Version" & @CRLF & _
"Extended Version" & @CRLF & _
"Original Mix" & @CRLF & _
"Extended Tech Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Talla 2XLC Extended Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Audien Remix" & @CRLF & _
"Extended Mix" & @CRLF & _
"Original Mix" & @CRLF & _
"Original Mix"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")