$re = '/^[a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}$/m';
$str = 'admin@gmail.com
admin+hello@gmail.com
admin@super.travel
admin@mail.ru
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);