#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?:\\b\\w+\\b[_!?\\s\\r\\n]*){3,7}$"
Local $sString = "ash asdg sdg asd adsw "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)