use strict;
my $str = 'ash asdg sdg asd adsw ';
my $regex = qr/^(?:\\b\\w+\\b[_!?\\s\\r\\n]*){3,7}$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";