// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:\\b\\w+\\b[_!?\\s\\r\\n]*){3,7}$").unwrap();
let string = "ash asdg sdg asd adsw ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}