using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{+([^{}]+)}\s*over\s*{([^{}]+)}+";
string input = @"{a} {b} over {c} {d}
{a} {{b} over {c}} {d}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}