re = /'\s*(?0)?[^']*'\K|(\w+)/
str = 'SELECT column_name FROM table_name WHERE column_name IN (\'A\' , \'st9u\' ,\'Meyer\', ....);
WHERE a.object_type IN (\' \'TABLE\'\', \'\'MATEerialIZED VIE3W\' \')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end