re = /\w+(?:'\w+)?|[^\w\s]/
str = 'I don\'t like to eat Cici\'s food (it is true)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end