using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(this\.\w+) \= (\w+);";
string input = @"this.name = name;";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}