use strict;
my $str = 'x (LOC)
ds ds (32C)
d\'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
';
my $regex = qr/ ?\(\w+\)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";