re = / ?\(\w+\)/
str = 'x (LOC)
ds ds (32C)
d\'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result