using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"3001-001-003";
string input = @"IN123456/10-3001-001-003";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}