#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?:START).*?(?:END)(?-s)|//.+|\. old|^\s+old(*SKIP)(*FAIL)|\b(old)\b"
Local $sString = "xx START xx old xx END xx --> ignore" & @CRLF & _
"xx old xx --> REPLACE !" & @CRLF & _
"START xx old --> ignore" & @CRLF & _
" xx old xx END --> ignore" & @CRLF & _
" xx old xx --> REPLACE !" & @CRLF & _
"// xx old --> ignore" & @CRLF & _
"xx // xx old --> ignore" & @CRLF & _
"xx . old old xx --> ignore first one, replace second one" & @CRLF & _
"." & @CRLF & _
" old --> ignore" & @CRLF & _
" (old) xx --> REPLACE !" & @CRLF & _
"xx old xx --> REPLACE !"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")