package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)(?:START).*?(?:END)(?-s)|//.+|\. old|^\s+old(*SKIP)(*FAIL)|\b(old)\b`)
var str = `xx START xx old xx END xx --> ignore
xx old xx --> REPLACE !
START xx old --> ignore
xx old xx END --> ignore
xx old xx --> REPLACE !
// xx old --> ignore
xx // xx old --> ignore
xx . old old xx --> ignore first one, replace second one
.
old --> ignore
(old) xx --> REPLACE !
xx old xx --> REPLACE !`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}