use strict;
my $str = '52 ';
my $regex = qr/(\\+?52[\\s\\-]?)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";