const regex = /(?<![\|\d|])(?P<gidnumber>\d+)\|(?P<rang>\d+)\|(?P<fonction>[A-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\|\\d|])(?P<gidnumber>\\d+)\\|(?P<rang>\\d+)\\|(?P<fonction>[A-Z]+)', 'g')
const str = `18909;11877;11872;5187|4|CHEF,789456;1237;11872;122|4|CHEF,18909;11877;11872;5187|4|CHEF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}