$re = '/(\d+)/';
$str = '<span class="labelbitdetail green"><i class="icon-thumbs-up norightmargin"></i>527</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);