package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)playstation.com`)
var str = `playstation.com
playstation4com.org
smetrics.aem.playstation.com
telemetry-console.api.playstation.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}