use strict;
my $str = '# Time: 230706 17:12:48
# User@Host: sample[sample] @ localhost []
# Thread_id: 626784 Schema: sample QC_hit: No
# Query_time: 2.976557 Lock_time: 0.000178 Rows_sent: 0 Rows_examined: 3344231
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688677968;
SELECT * from a;
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs;
# Time: 230706 17:13:37
# User@Host: sample[sample] @ localhost []
# Thread_id: 627027 Schema: oiemorug_wp598 QC_hit: No
# Query_time: 3.901325 Lock_time: 0.000145 Rows_sent: 0 Rows_examined: 3851050
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678017;
SELECT * from b
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs';
my $regex = qr/# Time.*?root.*?(?!# Time)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}