re = /^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9])(?=.*?[#$%^&*()\-_+={}[\]|\:;"'<>,.?\/]).{8,14}$/
str = '123456Abc#'
# Print the match result
str.match(re) do |match|
puts match.to_s
end