$re = '@http(?:(?!http).)*?/tempfiles/.*?\.jpg@m';
$str = 'blah blah <img src=http://somelink/file.html>http://server/tempfiles/blah.jpg
blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);