$re = '/\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\b/m';
$str = 'https://stackoverflow.com/v1/summary/1243PQ/details/P1/9981/P1P1P1P';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);