re = /£([^#£@]|#.)*@/m
str = 'fasdf asd£dfafsdafasdfasd## fdasdf #@ fdas #£ fdafasdsfd@ fasdfasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end