package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<claim-text>([^<\r\n]*)`)
var str = `<claim-text>aaaaaaa
<claim-text>bbbbbbb</claim-text>
<claim-text>ccccccc</claim-text>
</claim-text>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}