$re = '/(?<=\?name=)\w+/m';
$str = 'Example API - /api/test/regex/?name=ciara';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);