using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(?!(?:\/|https?))";
string substitution = @"\0/";
string input = @"href=""sdfsd
href=""/sdcs
href=""//svs
href=""http:
href=""https:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}