use strict;
my $str = 'href="sdfsd
href="/sdcs
href="//svs
href="http:
href="https:';
my $regex = qr/href="(?!(?:\/|https?))/mp;
my $subst = '\\0/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";