re = /^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$/
str = ' 476.068710 3 A1 Rx d 1 01 23 54'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end