// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))").unwrap();
let string = "2020-05-10 20:23:05";
let substitution = "日期\\1 时间\\5 \\2年\\3月\\4日 \\6时\\7分\\8秒";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}