$re = '/<(\d+)>.*?<\1>/';
$str = '<1>test<1>
<2>Test2<2>sfsaf<3><4>test<4>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);