package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:/[^\s:]\d{0,2})`)
var str = `2001:db8::/32
fe80::/10
2001:db8:101::/56
2001:db8:3c4d:15::/64 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}