import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:/[^\\s:]\\d{0,2})";
final String string = "2001:db8::/32\n"
+ "fe80::/10\n"
+ "2001:db8:101::/56\n"
+ "2001:db8:3c4d:15::/64 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}