const regex = new RegExp('((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:/[^\\s:]\\d{0,2})', 'gm')
const str = `2001:db8::/32
fe80::/10
2001:db8:101::/56
2001:db8:3c4d:15::/64 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}