#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:listget|name|number)\(([^\)]+)\)"
Local $sString = "name(abc1)" & @CRLF & _
"number(param9)" & @CRLF & _
"listget(12jtxgh)" & @CRLF & _
"(name(foo) & number(bar)) - listget(baz)" & @CRLF & _
"def number(param9)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")