import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:listget|name|number)\\(([^\\)]+)\\)";
final String string = "name(abc1)\n"
+ "number(param9)\n"
+ "listget(12jtxgh)\n"
+ "(name(foo) & number(bar)) - listget(baz)\n"
+ "def number(param9)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}