const regex = /(?:listget|name|number)\(([^\)]+)\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:listget|name|number)\\(([^\\)]+)\\)', 'gi')
const str = `name(abc1)
number(param9)
listget(12jtxgh)
(name(foo) & number(bar)) - listget(baz)
def number(param9)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}